@geekie/eslint-plugin

    1.0.3 • Public • Published

    ESLint utilities used at Geekie

    Installation

    Install using:

    $ yarn add --dev eslint eslint-plugin-geekie
    

    Usage

    Add geekie to your .eslintrc.json plugins:

    {
      "plugins": [
        "geekie"
      ]
    }

    And add one of the configs to extends:

    {
      "extends": [
        "plugin:@geekie/recommended"
      ]
    }

    Or add each rule individually:

    {
      "rules": {
        "@geekie/no-general-eslint-disable": "error"
      }
    }

    Configs

    The plugin exports two config:

    • rules: enables the rules included in the plugin
    • recommended: a sensible config for JS only, and enables the rules included in the plugin

    Rules

    The plugin exports two rules:

    • no-general-eslint-disable: disables usage of eslint-disable without specific rules, to prevent turning off linting completely in a line or in a file.
    • no-stringify-in-matcher: prevents usage of JSON.stringify in Jest matchers (it might work with others) because the serialization order is not reliable.

    Keywords

    none

    Install

    npm i @geekie/eslint-plugin

    DownloadsWeekly Downloads

    501

    Version

    1.0.3

    License

    MIT

    Unpacked Size

    5.74 kB

    Total Files

    9

    Last publish

    Collaborators

    • zonetti
    • mattbarros
    • izabelamelo
    • thomaz.morais
    • carlateo
    • leocpadua
    • rsalmeidafl
    • danielbucher
    • duailibe