Miss any of our Open RFC calls?Watch the recordings here! »

@gabehayes/eslint-config-flowtype

0.1.4 • Public • Published

eslint-config-flowtype

Check out eslint-plugin-flowtype for a list of all the rules we are inheriting.

Table of Contents

  1. Installation
  2. Rules
    1. flowtype/require-valid-file-annotation

Installation

Install the package.

yarn add @keenai/eslint-config-flowtype

Then, extend @keenai/react in your ESLint configuration file.

{
  extends: [
    '@keenai/flowtype',
  ],
}

Rules

flowtype/require-valid-file-annotation

Enforces the line style annotation at the top of all files.

Good

// @flow

Bad

/* @flow */

Keywords

none

Install

npm i @gabehayes/eslint-config-flowtype

DownloadsWeekly Downloads

3

Version

0.1.4

License

MIT

Last publish

Collaborators

  • avatar