Noisy Pillaging Monster

    This package has been deprecated

    Author message:

    Package no longer supported. Please use @flarum/cli instead.

    @friendsofflarum/create-flarum-extension

    1.5.4 • Public • Published

    Create Flarum Extension by FriendsOfFlarum

    npm version node npm downloads OpenCollective Donate

    Create a Flarum extension from a boilerplate in minutes!

    asciicast

    Quick Overview

    Using npx (npx comes with npm 5.2+ and higher):

    npx @friendsofflarum/create-flarum-extension [dir]

    Normally:

    npm install -g @friendsofflarum/create-flarum-extension
    create-flarum-extension [dir]

    Creating an Extension

    You’ll need to have Node >= 8 on your local development machine. You can use n to interactively manage your node versions.

    To create a new app, run a single command:

    npx @friendsofflarum/create-flarum-extension my-extension
    

    (npx comes with npm 5.2+ and higher, see quick overview for older npm versions)

    It will create a directory called my-extension inside the current folder. Inside that directory, it will generate the initial project structure:

    my-extension
    ├── .gitignore
    ├── .gitattributes
    ├── composer.json
    ├── extend.php
    ├── LICENSE.md
    ├── README.md
    ├── js
    │  ├── admin.js
    │  ├── forum.js
    │  ├── package.json
    │  ├── webpack.config.js
    │  └── src
    │     ├── admin
    │     │  └── index.js
    │     └── forum
    │        └── index.js
    └── resources
       ├── less
       │  ├── admin.less
       │  └── forum.less
       └── locale
          └── en.yml
    

    Flarum Resources

    Links

    A utility by FriendsOfFlarum.

    Install

    npm i @friendsofflarum/create-flarum-extension

    DownloadsWeekly Downloads

    6

    Version

    1.5.4

    License

    MIT

    Unpacked Size

    20.2 kB

    Total Files

    21

    Last publish

    Collaborators

    • datitisev