Ready to take your JavaScript development to the next level? Meet npm Enterprise - the ultimate in enterprise JavaScript. Learn more »

@fourdigit/eslint-config-fourdigit

1.0.6 • Public • Published

ESLint Sharable Config for FOURDIGIT

npm Build Status Greenkeeper badge

This package is sharable config of ESLint used in the FOURDIGIT project.

Installation

// npm
$ npm install --save-dev @fourdigit/eslint-config-fourdigit

// yarn
$ yarn add --dev @fourdigit/eslint-config-fourdigit

Usage

Base + ES2018 + React

ES2018 + Reactのコードベース用設定ファイルです。 プロジェクトの.eslintrcに以下のように記述してください。

{
  "root": true,
  "extends": ["@fourdigit/eslint-config-fourdigit"]
}

Base + ES2018

ES2018のコードベース用設定ファイルです。 プロジェクトの.eslintrcに以下のように記述してください。

{
  "root": true,
  "extends": ["@fourdigit/eslint-config-fourdigit/esnext"]
}

ES2018以前のECMAScriptのバージョンを使用する場合は、以下のような記述もしてください。

{
  parserOptions: {
    ecmaVersion: 2015
  }
}

Base

ES5のコードベース用設定ファイルです。 プロジェクトの.eslintrcに以下のように記述してください。

{
  "root": true,
  "extends": ["@fourdigit/eslint-config-fourdigit/base"]
}

Prettier

プロジェクト内で.prettierrc.jsを用意して、以下のように記述をしてください。

module.exports = require('@fourdigit/eslint-config-fourdigit/.prettierrc.js')

install

npm i @fourdigit/eslint-config-fourdigit

Downloadsweekly downloads

50

version

1.0.6

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
  • avatar
Report a vulnerability