Norvell, Please Merge

    @forter/eslint-config

    1.4.6 • Public • Published

    Linting ESLint

    Use ESLint to lint your es6 code.

    👨‍🏭Installation

    • Install @forter/eslint
    npm i @forter/eslint-config --save-dev
    • Adjust your package.json with the following
      {
        "scripts": {
          "lint:eslint": "eslint --ext .js,.html . --ignore-path .gitignore",
          "format:eslint": "eslint --ext .js,.html . --fix --ignore-path .gitignore"
        },
        "eslintConfig": {
          "extends": [
            "@forter/eslint-config"
          ]
        }
      }

    👩‍🚀 What you get

    Extends eslint-config-google.

    This will install @forter/eslint-config, a config based on google but allows for some specialities needed for Web Components.

    • Apply linting to js and html files
    • Apply linting for best practices
    • Allow dynamic module imports
    • Allow imports in test/demos from devDependencies
    • Allow underscore dangle
    • Do not prefer default exports
    • Do not prefer no file extension

    👨‍💻 Usage

    Run:

    • npm run lint:eslint to check if any file is not correctly formatted
    • npm run format:eslint to auto format your files
    <script>
      export default {
        mounted() {
          const editLink = document.querySelector('.edit-link a');
          if (editLink) {
            const url = editLink.href;
            editLink.href = url.substr(0, url.indexOf('/master/')) + '/master/packages/eslint-config/README.md';
          }
        }
      }
    </script>

    Keywords

    Install

    npm i @forter/eslint-config

    DownloadsWeekly Downloads

    0

    Version

    1.4.6

    License

    Apache-2.0

    Unpacked Size

    19.9 kB

    Total Files

    5

    Last publish

    Collaborators

    • forter-npm
    • lirown
    • oweingart