Narnia's Poofy Meatcleaver

    @eveble/eveble
    TypeScript icon, indicating that this package has built-in type declarations

    2.3.0 • Public • Published

    banner



    Event Sourcing framework for Node.js

    Eveble is an event sourcing framework with modular architecture for DDD(Domain Driven Design) applications in Node.js


    Requirements

    Installation

    To use install Eveble:

    npm install @eveble/eveble

    or

    yarn add @eveble/eveble

    You'll also need to setup development environment or use directly our boilerplate to create new project.

    Complementary Packages

    Most likely, you'll also need the Eveble testing framework:

    npm install @eveble/eveble
    npm install --save-dev @eveble/testing

    Create a Eveble App

    The recommended way to start new apps with Eveble is by using the official Eveble boilerplate:

    # Clone the repository
    $ git clone https://github.com/eveble/eveble-boilerplate.git <YOUR_PROJECT_NAME>
    # Go into the repository
    $ cd <YOUR_PROJECT_NAME>
    # Run setup
    $ npm run setup

    Documentation

    The @eveble/eveble docs are now published at https://eveble.github.io/eveble/ .

    License

    MIT

    Install

    npm i @eveble/eveble

    DownloadsWeekly Downloads

    16

    Version

    2.3.0

    License

    MIT

    Unpacked Size

    832 kB

    Total Files

    106

    Last publish

    Collaborators

    • eveble-user
    • desivi