This package has been deprecated

Author message:

use @dizmo/dizmo.js instead

@dizmo/types-viewer
TypeScript icon, indicating that this package has built-in type declarations

1.0.6 • Public • Published

NPM version Build Status Coverage Status

@dizmo/types-viewer

Library module.

Usage

Install

npm install @dizmo/types-viewer --save-dev

Require

const { Viewer } = require('@dizmo/types-viewer');

Examples

import Viewer from '@dizmo/types-viewer'
declare const viewer: Viewer;

Development

Clean

npm run clean

Build

npm run build

without linting and cleaning:

npm run -- build --no-lint --no-clean

with UMD bundling (incl. minimization):

npm run -- build --prepack

with UMD bundling (excl. minimization):

npm run -- build --prepack --no-minify

Lint

npm run lint

with auto-fixing:

npm run -- lint --fix

Test

npm run test

without linting, cleaning and (re-)building:

npm run -- test --no-lint --no-clean --no-build

Cover

npm run cover

without linting, cleaning and (re-)building:

npm run -- cover --no-lint --no-clean --no-build

Publish

npm publish

initially (if public):

npm publish --access=public

Copyright

© 2019 dizmo AG, Switzerland

Install

npm i @dizmo/types-viewer

DownloadsWeekly Downloads

1

Version

1.0.6

License

ISC

Unpacked Size

19.9 kB

Total Files

11

Last publish

Collaborators

  • dizmo-user
  • hsk81