@csstools/postcss-normalize-display-values
TypeScript icon, indicating that this package has built-in type declarations

3.0.2 • Public • Published

PostCSS Normalize Display Values PostCSS Logo

npm version CSS Standard Status Build Status Discord

PostCSS Normalize Display Values lets you specify definition of outer and inner displays types for an element.

.element {
  display: inline flow-root;
}

/* becomes */

.element {
  display: inline-block;
  display: inline flow-root;
}

See prior work by cssnano here postcss-normalize-display-values To ensure long term maintenance and to provide the needed features this plugin was recreated based on cssnano's work.

Usage

Add PostCSS Normalize Display Values to your project:

npm install postcss @csstools/postcss-normalize-display-values --save-dev

Use it as a PostCSS plugin:

const postcss = require('postcss');
const postcssNormalizeDisplayValues = require('@csstools/postcss-normalize-display-values');

postcss([
  postcssNormalizeDisplayValues(/* pluginOptions */)
]).process(YOUR_CSS /*, processOptions */);

PostCSS Normalize Display Values runs in all Node environments, with special instructions for:

Node PostCSS CLI Webpack Gulp Grunt

Options

preserve

The preserve option determines whether the original source is preserved. By default, it is preserved.

postcssNormalizeDisplayValues({ preserve: false })
.element {
  display: inline flow-root;
}

/* becomes */

.element {
  display: inline-block; 
}

Package Sidebar

Install

npm i @csstools/postcss-normalize-display-values

Weekly Downloads

3,800,769

Version

3.0.2

License

MIT-0

Unpacked Size

8.57 kB

Total Files

7

Last publish

Collaborators

  • romainmenke
  • alaguna
  • jonathantneal