Nodeschool Public Materials

    @comunica/actor-rdf-update-quads-hypermedia
    TypeScript icon, indicating that this package has built-in type declarations

    2.3.0 • Public • Published

    Comunica Hypermedia RDF Update Quads Actor

    npm version

    An RDF Update Quads actor that handles hypermedia-based destinations.

    This module is part of the Comunica framework, and should only be used by developers that want to build their own query engine.

    Click here if you just want to query with Comunica.

    Install

    $ yarn add @comunica/actor-rdf-update-quads-hypermedia

    Configure

    After installing, this package can be added to your engine's configuration as follows:

    {
      "@context": [
        ...
        "https://linkedsoftwaredependencies.org/bundles/npm/@comunica/actor-rdf-update-quads-hypermedia/^2.0.0/components/context.jsonld"  
      ],
      "actors": [
        ...
        {
          "@id": "urn:comunica:default:rdf-update-quads/actors#hypermedia",
          "@type": "ActorRdfUpdateQuadsHypermedia",
          "mediatorDereferenceRdf": { "@id": "urn:comunica:default:dereference-rdf/mediators#main" },
          "mediatorMetadata": { "@id": "urn:comunica:default:rdf-metadata/mediators#main" },
          "mediatorMetadataExtract": { "@id": "urn:comunica:default:rdf-metadata-extract/mediators#main" },
          "mediatorRdfUpdateHypermedia": { "@id": "urn:comunica:default:rdf-update-hypermedia/mediators#main" }
        }
      ]
    }
    

    Config Parameters

    Install

    npm i @comunica/actor-rdf-update-quads-hypermedia

    DownloadsWeekly Downloads

    2,656

    Version

    2.3.0

    License

    MIT

    Unpacked Size

    29.4 kB

    Total Files

    10

    Last publish

    Collaborators

    • jeswr
    • joachimvh
    • rubensworks
    • rubenverborgh
    • dexagod