Nuclear Pumpkin Mayhem

    @citation-js/plugin-orcid

    0.3.1 • Public • Published

    Install

    npm install @citation-js/plugin-orcid

    Note: this plugin requires @citation-js/plugin-doi, so be sure to install that one as well if you have not already. It is automatically included in the citation-js package.

    Use

    Install the plugin by require-ing it:

    require('@citation-js/plugin-orcid')

    Formats

    Formats and other features added by this plugin.

    Input

    ORCID IDs

    Create a bibliography from an ORCID ID:

    const { Cite } = require('@citation-js/core')
    require('@citation-js/plugin-orcid')
    
    Cite
      .async('0000-0000-0000-0000')
      .then(cite => cite.format( ... ))

    You can also use the Replacer API, by downloading a bundle with the Replacer functionality, the CSL output plugin and this plugin (download link):

    <!-- Please *download* the file linked above, since there is no built-in caching -->
    <script src="bundle.js"></script>
    
    <div class="citation-js" data-input="0000-0000-0000-0000" data-output-format="bibliography" data-output-template="apa">
      Placeholder markup for if Citation.js does not work.
    
      For example, link to <a href="https://orcid.org/0000-0000-0000-0000">your ORCID profile</a> instead!
    </div>

    Install

    npm i @citation-js/plugin-orcid

    DownloadsWeekly Downloads

    10

    Version

    0.3.1

    License

    MIT

    Unpacked Size

    5.69 kB

    Total Files

    5

    Last publish

    Collaborators

    • larsgw