Now, Please Meander

    @chelpis/eslint-config

    1.1.1 • Public • Published

    ESLint shareable config for Chelpis

    ESLint shareable config for Chelpis internal use.

    Make sure to install eslint and all of the following plugins

    • eslint-config-prettier: >= 6.11.0
    • eslint-config-react-app: >= 5.2.1
    • eslint-loader: >= 4.0.2
    • eslint-plugin-import: >= 2.22.0
    • eslint-plugin-jsx-a11y: >= 6.3.1
    • eslint-plugin-react: >= 7.20.6
    • eslint-plugin-react-hooks: >= 4.1.0
    • eslint-plugin-simple-import-sort: >= 5.0.3
    • @typescript-eslint/eslint-plugin: >= 3.9.1
    • @typescript-eslint/parser: >= 3.9.1

    Also add .eslintrc with the following:

    { "extends": ["@chelpis/eslint-config"] }

    Keywords

    none

    Install

    npm i @chelpis/eslint-config

    DownloadsWeekly Downloads

    2

    Version

    1.1.1

    License

    ISC

    Unpacked Size

    1.95 kB

    Total Files

    3

    Last publish

    Collaborators

    • roadmanfong
    • ce.lee