This package has been deprecated

Author message:

This eslint config is deprecated in favor of @bloomreach/eslint-config-base

@bloomreach/eslint-config

0.1.0 • Public • Published

Bloomreach ESLint Config

NPM License

The package provides an ESLint configuration for the Bloomreach Frontend Code Style.

What is inside?

  • Based on Airbnb's shared config.
  • TypeScript configuration.
  • Prettier configuration.
  • React configuration.

Get Started

Installation

To get the SDK into your project with NPM:

npm install --save-dev @bloomreach/eslint-config

And with Yarn:

yarn add --dev @bloomreach/eslint-config

Usage

Add the following configuration into your package.json:

  "eslintConfig": {
    "extends": "@bloomreach/eslint-config"
  },

License

Published under Apache 2.0 license.

Readme

Keywords

none

Package Sidebar

Install

npm i @bloomreach/eslint-config

Weekly Downloads

203

Version

0.1.0

License

Apache-2.0

Unpacked Size

4.88 kB

Total Files

4

Last publish

Collaborators

  • vahid.mehrjouei
  • stefanos.maziotis
  • prateek.pandey
  • shivanayak.dharavath2
  • feix-bloomreach
  • jeroenhoffman
  • skuzey-br
  • aakash.anand
  • rameshbr
  • boudekerk
  • mgiusto
  • beetlerom
  • joerideg
  • abogaart
  • pcentgraf-bloomreach
  • mjmetter
  • michielrop
  • sshepelevich
  • vlets
  • pauledwardsbloomreach
  • davidboyd1
  • br-mikedreynolds
  • tom.washek
  • drq
  • ricardomartins
  • ntrajkovski
  • bcanvural
  • lachire
  • brxm
  • glm-bloomreach
  • vaibhav.shukla
  • hachok
  • vkauryha