@blitz/eslint-plugin

0.0.44 • Public • Published

@blitz/eslint-plugin

An ESLint plugin to enforce a consistent code styles across StackBlitz projects

Installation

You'll first need to install ESLint:

$ yarn add -D eslint

Next, install @blitz/eslint-plugin:

$ yarn add -D @blitz/eslint-plugin

Note: If you installed ESLint globally (using the -g flag) then you must also install @blitz/eslint-plugin globally.

Usage

Add @blitz/eslint-plugin to the extends section of your .eslintrc.js or .eslintrc.json configuration file and and configure parser and parserOptions. For the plugin, you can omit the eslint-plugin-:

{
  "parser": "@typescript-eslint/parser",
  "parserOptions": {
    "ecmaVersion": 2019,
    "sourceType": "module",
    "ecmaFeatures": {
      "modules": true
    }
  },
  "extends": ["plugin:@blitz/recommended"]
}

Custom Rules

Package Sidebar

Install

npm i @blitz/eslint-plugin

Weekly Downloads

82

Version

0.0.44

License

MIT

Unpacked Size

71.9 kB

Total Files

28

Last publish

Collaborators

  • cassiozen
  • tsulkowski
  • alexkalderimis
  • kirjava
  • nemikolh
  • donmckenna
  • fvsch
  • stackblitz-devops
  • ykmsd
  • heygarrison
  • ggdaltoso
  • markwhitfeld
  • apai4
  • samdd
  • ericmsimons
  • stackblitz-unpkg
  • d3lm
  • kwintenp
  • samverschueren
  • _rvidal