npm

Need private packages and team management tools?Check out npm Orgs. »

@atlauncher/eslint-plugin-atlauncher

0.3.0 • Public • Published

@atlauncher/eslint-plugin-atlauncher

Custom ESLint rules for use with eslint-config-atlauncher

Installation

You'll first need to install ESLint:

npm i eslint --save-dev

Next, install @atlauncher/eslint-plugin-atlauncher:

npm install @atlauncher/eslint-plugin-atlauncher --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install @atlauncher/eslint-plugin-atlauncher globally.

Usage

Add @atlauncher/atlauncher to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:

{
  "plugins": [
    "@atlauncher/atlauncher"
  ]
}

Then configure the rules you want to use under the rules section.

{
  "rules": {
    "atlauncher/rule-name": 2
  }
}

Supported Rules

  • atlauncher/require-jsdoc - this is the same as the ESLint 'require-jsdoc' rule, but provides an extra 'ignore' option for function/method/class names to ignore

install

npm i @atlauncher/eslint-plugin-atlauncher

Downloadsweekly downloads

0

version

0.3.0

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
Report a vulnerability