Now Particularly Misnamed

    This package has been deprecated

    Author message:

    Do not use this package directly. It is affected by security vulernability from its upstream fork. Please use `graphql-playground-middleware-express` directly, which has resolved the vulnerability in more recent versions. See https://git.io/JfSaF for details on impacted versions and the vulnerability.

    @apollographql/graphql-playground-middleware-express
    TypeScript icon, indicating that this package has built-in type declarations

    1.7.15 • Public • Published

    graphql-playground-middleware-express

    Express middleware to expose an endpoint for the GraphQL Playground IDE

    Installation

    Using yarn:

    yarn add graphql-playground-middleware-express

    Or npm:

    npm install graphql-playground-middleware-express --save

    Usage

    See full example in examples/basic.

    const express = require('express')
    const expressPlayground = require('graphql-playground-middleware-express')
      .default
    
    const app = express()
    
    app.get('/playground', expressPlayground({ endpoint: '/graphql' }))

    Install

    npm i @apollographql/graphql-playground-middleware-express

    DownloadsWeekly Downloads

    3

    Version

    1.7.15

    License

    MIT

    Unpacked Size

    3.15 kB

    Total Files

    7

    Last publish

    Collaborators

    • abernix
    • apollo-bot
    • hwillson
    • jbaxleyiii
    • martijnwalraven
    • nim