@apimediaru/eslint-config-base

1.0.23 • Public • Published

eslint-config-base

This package provides base JS .eslintrc (without plugins) as an extensible shared config.

Usage

Our default export contains all of our ESLint rules, including ECMAScript 6+. It requires eslint and eslint-plugin-import.

  1. Install the correct versions of each package, which are listed by the command:
npm info "@apimediaru/eslint-config-base@latest" peerDependencies

If using npm 5+, use this shortcut

npx install-peerdeps --dev @apimediaru/eslint-config-base

If using yarn, you can also use the shortcut described above if you have npm 5+ installed on your machine, as the command will detect that you are using yarn and will act accordingly. Otherwise, run npm info "@apimediaru/eslint-config-base@latest" peerDependencies to list the peer dependencies and versions, then run yarn add --dev <dependency>@<version> for each listed peer dependency.

  1. Add "extends": "@apimediaru/eslint-config-base" to your .eslintrc.

Package Sidebar

Install

npm i @apimediaru/eslint-config-base

Weekly Downloads

2

Version

1.0.23

License

MIT

Unpacked Size

65 kB

Total Files

11

Last publish

Collaborators

  • graandy
  • exileofaranei