Learn about our RFC process, Open RFC meetings & more.Join in the discussion! »

@alkafinance/eslint-config

1.4.1 • Public • Published

@alkafinance/eslint-config

npm version CircleCI Status license: MIT dependencies Status devDependencies Status

Alka base ESLint config. Intended to be used together with prettier.

Usage

This config relies dangerously on npm@3/yarn flatter tree for its dependencies (because of eslint/issues/3458), so installation may be as simple as:

$ yarn add eslint prettier @alkafinance/eslint-config --dev
# or 
$ npm install eslint prettier @alkafinance/eslint-config --save-dev

Then add the extends to your .eslintrc.js:

module.exports = {
  extends: '@alkafinance/eslint-config',
  rules: {
    // your overrides
  },
};

Other configs

This config also exposes a few other configs that we use often and pull in as needed.

You can use them standalone:

module.exports = {
  extends: '@alkafinance/eslint-config/<config-name>',
};

Or in combination with the base config (recommended):

module.exports = {
  extends: [
    '@alkafinance/eslint-config',
    '@alkafinance/eslint-config/<config-name>',
  ],
};

You can also use ESLint@4 overrides to apply a config only to certain files. For example:

module.exports = {
  ...
  overrides: [
    {
      files: ['**/__tests__/*-test.js', '**/__mocks__/*.js'],
      extends: '@alkafinance/eslint-config/jest',
    },
  ],
};

Available configs include:

  • '@alkafinance/eslint-config/jest' for Jest related rules
  • '@alkafinance/eslint-config/script' for usage with config files or scripts

License

MIT License © Alka, Inc

Install

npm i @alkafinance/eslint-config

DownloadsWeekly Downloads

30

Version

1.4.1

License

MIT

Unpacked Size

9.43 kB

Total Files

6

Last publish

Collaborators

  • avatar