Nonsense Parser Microframework

    @alexdiliberto/eslint-config

    6.0.1 • Public • Published

    @alexdiliberto/eslint-config

    Build status Commitizen friendly

    Shareable config for all of my preferred ESLint rules.

    Installation

    yarn add -D @alexdiliberto/eslint-config

    OR

    npm install --save-dev @alexdiliberto/eslint-config

    Next, install all necessary peer dependencies as notified via console after running the above command.

    Alternatively, if you are using this eslint-config with an Ember CLI project -- simply ensure that the ember-cli-eslint addon is installed with version >= v5.0.0 and that will take care of the necessary peer dependencies for you automatically.

    Usage

    Add @alexdiliberto to the extends array in your project's .eslintrc.js file as a shorthand and these sharable config rules will be automatically consumed by ESLint from within your project.

    {
      extends: ['@alexdiliberto']
    }

    Using the @alexdiliberto/eslint-config config with eslint:recommended

    To use this config in conjunction with ESLint's core eslint:recommended ruleset, extend them both, making sure to list @alexdiliberto last. Please note that I have made it a priority to try not override any of ESLint's recommended rules unless explicitly noted in comments -- this serves only as a precautionary measure to ensure overrides.

    {
      extends: [
        'eslint:recommended',
        '@alexdiliberto'
      ]
    }

    Deploy

    Due to an issue with yarn, simply use npm when running the deploy script

    npm run release

    License

    MIT Copyright (c) Alex DiLiberto

    Install

    npm i @alexdiliberto/eslint-config

    DownloadsWeekly Downloads

    103

    Version

    6.0.1

    License

    MIT

    Unpacked Size

    72.6 kB

    Total Files

    17

    Last publish

    Collaborators

    • alexdiliberto