@ahsdile/canvas-lms-restrict-sis-course-settings-plugin

    0.2.0 • Public • Published

    Canvas LMS Restrict SIS Course Settings Plug-in

    Plugin for the Canvas LMS theme app that restricts some settings in courses created by the SIS import/sync.

    Installation

    Using NPM:

    npm install @ahsdile/canvas-lms-restrict-sis-course-settings-plugin
    

    Using Yarn:

    yarn add @ahsdile/canvas-lms-restrict-sis-course-settings-plugin
    

    Usage

    Just import the plug-in and add it to the Canvas app:

    import canvas from '@ahsdile/canvas-lms-app';
    import restrictSISCourseSettingsPlugin from '@ahsdile/canvas-lms-restrict-sis-course-settings-plugin';
    
    canvas.addPlugin(restrictSISCourseSettingsPlugin);
    
    canvas.run();

    Keywords

    Install

    npm i @ahsdile/canvas-lms-restrict-sis-course-settings-plugin

    DownloadsWeekly Downloads

    4

    Version

    0.2.0

    License

    MIT

    Unpacked Size

    3.63 kB

    Total Files

    10

    Last publish

    Collaborators

    • digitaalleren
    • renaatdemuynck