@activfinancial/cg-api
    TypeScript icon, indicating that this package has built-in type declarations

    0.16.1 • Public • Published

    A JavaScript API (with TypeScript definitions) to access the ACTIV ContentGateway.

    Prerequisites

    The API uses WebAssembly and as such requires quite recent versions of JavaScript run-times.

    Browser versions

    https://caniuse.com/#feat=wasm

    • Firefox 54 or higher.
    • Chrome 61 or higher.
    • Edge 40.15063.0.0 (Windows 10 Creators Update) or higher. You may need to enable experimental JavaScript features in about:flags for versions prior to Windows 10 Fall Creators Update.
    • Safari 11 or higher.

    Node version

    8 or higher.

    OpenFin version

    9 or higher.

    Programming with the API

    To see how the API can be used, read our getting started tutorial.

    There is also a minimal starter application in a separate repository available here.

    Keywords

    none

    Install

    npm i @activfinancial/cg-api

    DownloadsWeekly Downloads

    207

    Version

    0.16.1

    License

    CC-BY-ND-4.0

    Unpacked Size

    5.25 MB

    Total Files

    9

    Last publish

    Collaborators

    • martinbirks
    • lukebelliott