Newsworthy Presidential Mistakes
html-pages

Path Traversal

Severity: high

Overview

Versions of html-pages before 2.1.0 are vulnerable to path traversal.

Remediation

Update to version 2.1.0 or later.

Vulnerable versions

0.0.1
a year ago
0.0.2
a year ago
0.0.3
a year ago
0.0.5
a year ago
0.0.12
a year ago
0.0.14
a year ago
0.0.88
a year ago
0.0.89
a year ago
0.0.90
a year ago
1.0.0
a year ago
1.1.0
a year ago
1.2.0
a year ago
1.2.1
a year ago
1.5.0
a year ago
1.5.1
a year ago
1.5.2
a year ago
1.5.3
a year ago
1.6.0
a year ago
1.7.0
a year ago
1.7.1
a year ago
1.7.2
a year ago
1.7.3
a year ago
2.0.0
a year ago
2.0.1
a year ago
2.0.2
a year ago
2.0.3
a year ago
2.0.4
10 months ago
2.0.5
10 months ago
2.0.6
9 months ago
2.0.7
7 months ago
2.0.8
7 months ago
2.0.9
6 months ago

Unaffected versions

2.1.0
5 months ago
2.1.1
5 months ago
2.1.2
4 months ago

Resources

Advisory timeline

  1. published

    Advisory published
    May 16th, 2018
  2. reported

    May 16th, 2018