npm

Severity: high

Directory Traversal

@vivaxy/here

Overview

The @vivaxy/here module is a small web server that serves files with the process' working directory acting as the web root.

It is vulnerable to a directory traversal attack.

This means that files on the local file system which exist outside of the web root may be disclosed to an attacker. This might include confidential files.

Mitigating Factors: If the node process is run as a user with very limited filesystem permissions, there is significantly less risk of exposing confidential/private information.

Proof of Concept:

curl "http://${SERVER_IP}:${SERVER_PORT}/..%2f..%2fetc/passwd"

Remediation

Run npm i @vivaxy/here to install the latest version that addresses this vulnerability.

Have content suggestions? Send them to [email protected]

Advisory timeline

  1. published

    Advisory published
    Jan 15th, 2018
  2. reported

    Initial report by Yasin Soliman
    Jan 15th, 2018