exxxxxxxxxxx

Directory Traversal

Severity: high

Overview

Affected versions of exxxxxxxxxxx resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system.

This vulnerability is only effective for files that have a file extension, which provides a partial mitigation.

Example request:

GET /../../../../../../../../../../etc/passwd HTTP/1.1
host:foo

Remediation

No patch is available for this vulnerability.

It is recommended that the package is only used for local development, and if the functionality is needed for production, a different package is used instead.

Vulnerable versions

1.0.0
3 years ago
1.0.2
3 years ago

Unaffected versions

Advisory timeline

  1. Published

    Advisory published
    Sep 26th, 2017
  2. Reported

    Initial report by Liang Gong
    Jul 20th, 2017