npm

Severity: high

Downloads Resources over HTTP

nodewebkit

Overview

Affected versions of nodewebkit insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running nodewebkit.

Remediation

No patch is currently available, and the package author has deprecated this package.

The best path forward in mitigating this vulnerability is to use the official installer instead of this package, as per the package author's instructions.

Have content suggestions? Send them to [email protected]

Advisory timeline

  1. published

    Advisory published
    Dec 18th, 2016
  2. reported

    Initial report by Adam Baldwin
    Nov 30th, 2016