unicode

Downloads Resources over HTTP

Severity: high

Overview

Affected versions of unicode insecurely download resources over HTTP.

In scenarios where an attacker has a privileged network position, they can modify or read such resources at will. While the exact severity of impact for a vulnerability like this is highly variable and depends on the behavior of the package itself, it ranges from being able to read sensitive information all the way up to and including remote code execution.

Remediation

Update to version 9.0.0 or later.

Vulnerable versions

0.0.1
7 years ago
0.1.0
7 years ago
0.1.1
7 years ago
0.1.2
7 years ago
0.1.3
7 years ago
0.1.4
7 years ago
0.2.0
7 years ago
0.2.1
7 years ago
0.3.0
7 years ago
0.3.1
7 years ago
0.4.0
6 years ago
0.4.1
6 years ago
0.4.2
6 years ago
0.4.3
6 years ago
0.4.4
5 years ago
0.4.5
5 years ago
0.4.6
5 years ago
0.4.7
5 years ago
0.4.8
5 years ago
0.4.9
5 years ago
0.5.0
5 years ago
0.5.1
5 years ago
0.5.2
5 years ago
0.5.3
5 years ago
0.6.0
4 years ago
0.6.1
3 years ago

Unaffected versions

0.1.3-1
7 years ago
0.1.3-2
7 years ago
0.1.3-3
7 years ago
0.1.3-4
7 years ago
0.1.3-5
7 years ago
0.1.3-6
7 years ago
0.1.3-7
7 years ago
9.0.0
a year ago
9.0.1
a year ago
10.0.0
a year ago
11.0.0
2 months ago
11.0.1
2 months ago

Advisory timeline

  1. published

    Advisory published
    Dec 18th, 2016
  2. reported

    Nov 30th, 2016