Remote Memory Exposurebl
A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1 <2.2.1 and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.
Upgrade to version 4.0.3, 3.0.1, 2.2.1 or 1.2.3.
publishedAdvisory PublishedSep 8th, 2020
reportedReported by chalkerSep 8th, 2020