Severity: high

Denial of Service

@commercial/hapi

Overview

Affected versions of @commercial/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Remediation

Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.

Have content suggestions? Send them to [email protected]

Advisory timeline

  1. published

    Advisory Published
    Feb 17th, 2020
  2. reported

    Reported by Eran Hammer
    Feb 17th, 2020