npm

Severity: moderate

Spoofing attack due to unvalidated KDC

node-krb5

Overview

Affected versions of node-krb5 do not validate the KDC prior to authenticating, which might allow an attacker with network access and enough time to spoof the KDC and impersonate a valid user without knowing their credentials.

Remediation

It appears that this will remain unfixed indefinitely, as the Github issue for this vulnerability has been open since 2015, with no work on it since then.

At this time, the best available mitigation is to use an alternative module that is actively maintained and provides similar functionality. There are multiple modules fitting this criteria available on npm..

Have content suggestions? Send them to [email protected]

Advisory timeline

  1. published

    Advisory published
    Aug 4th, 2016
  2. reported

    Initial report by Richard Silverman
    Aug 4th, 2016