Severity: high

Arbitrary File Write

decompress

Overview

Versions of decompress prior to 4.2.1 are vulnerable to Arbitrary File Write. The package fails to prevent extraction of files with relative paths, allowing attackers to write to any folder in the system by including filenames containing../.

Remediation

Upgrade to version 4.2.1 or later.

Have content suggestions? Send them to [email protected]

Advisory timeline

  1. published

    Advisory Published
    Feb 26th, 2020
  2. reported

    Reported by Oscar Arnflo
    Oct 15th, 2019